Jump to content

10 steps forward one step back


Recommended Posts

I was wondering if anyone else has those little things that pop-up in your display once you start putting power to everything.

I test all my lights before anything goes into the yard well.... tonight I started putting power to some of the elements and bang, zap, done. Half the lower roof's green LEDs are out.

So on Friday I'll have to go up on the ladder and see what happened. The Green LEDs I have only need to last this one year. I've not repaired LEDs before so this should be interesting. I'll start with the fuses. It was dark so I'm not sure where in the string the lights go out. Everything behind a particular point is dark.

Link to post
Share on other sites

I had bulb issues this year and last...I've lost 30-40 Red c9 bulbs from Action Lighting. I had to put in another order last night to get more bulbs...and it doesn't help that my siblings play target practice with my lights (yes, they shattered a few yesterday)....

Link to post
Share on other sites

So far so good here, with the power and lights... But my delimas lie in the actual sequencing. My display isn't that large, but it's pretty complex. I have a lot of stuff and it's spread over a lot that's wider than it is deep, and all the way to the road... Lyman (Xtreme christmas displays) is doing my sequencing, and saved mine for last. He is NOT liking it at all, and is having trouble getting everything incorperated. I wish I could have laid out the display differently, but I also didn't want to only do half of what I usually do just to make it more "symmetrical".

Link to post
Share on other sites

There's always something...Mr Murphy is hard at work around my house too.

It's usually the hard to get to stuff. I check every light going up on my roof. I even install them while lit up. I even leave them lit up till I'm done... Of course when I shut them off then back on half a string here half a string there...

Argh!

Link to post
Share on other sites
Guest showtime

Lol I got Direct tv installed and the installer cut right through a strand of lights against the house! On the other side of the house he just let one set of lights hang there WOW! I know I can do a better install than this guy!

Link to post
Share on other sites

I have checked the lights that go on my mega-tree, once before I packed them away and again when I up rolled them. They all worked, and of course after I crank up my lights to the top and got them spaced out. I have 3 strings out of 192 that the top half is out, sure wish it was the bottom half. Will be checking them out off a TALL ladder...grrrrrr

Link to post
Share on other sites

Rabbits already got my LED C-9 lights on stakes around the perimeter of my front yard... Have to splice that. Few C-7 bulbs out again. Big snowflake is still being tempermental, same section I just fixed is out again. Also have an LED snowflake that mysteriously didn't light tonight... Plus I still have a LOT to put up for my backyard display. All this and I'm not even running my show yet!

Link to post
Share on other sites

I keep adding to, taking away, or moving parts of the display (static, not animated).

"doesn't look right here, needs to be 2' over"

"crap, need another extension cord now"

Icicles lights losing a section, can't find the issue. Replace with a NEW strand (same make/model) and it is about a foot shorter.

And other plans not coming together like I want them to (not enough lights, but still way too many for the power I have~~ or don't have).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...