Jump to content

Recommended Posts

Don,

Hello from your ex-Melbourne neighbor. I've used the Xenon strobes from CLS for the last few years (you've seen them in the display) and they have worked well for me. How are things down in Fla? First day of hurricane season, right?

Link to post
Share on other sites
  • 4 weeks later...

I have strobes from cls as well,the ones I have flash 3 to 4 times a second.I bought some from wow lights ,but they only flash 1 to 2 times a second. I liked the faster rate seems to sparkle better. the ones from wow lights are well made,the only thing about the cls strobes are that the sockets comes loose from the base, still an easy fix

Link to post
Share on other sites

I have both and have all the same problems. I run both. That way it is a different flash rate all around. Be sure they are not on the same line. If you are using one channel you need to run a splitter for the separate lines. Look towards the end of this video and you will see what I mean;

[media=]

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...