Jump to content

Recommended Posts

I have the Mickey, Minnie, and Pluto teacup inflatable.  After a bad rainstorm the other day, Mickey and Minnie no longer turn correctly.  They move a tiny, tiny bit but they it seems as if they are caught on something.  I tried looking and don't see any twisted wires on anything.  Has anyone else ever had this problem?

Link to post
Share on other sites

I have a similar problem with the Snowball Cannon inflatable.  The day we put it up (and in past years) it worked fine.  But, after 3 days of rain, it no longer turns.

 

I am thinking of bringing it in to a heated garage to run it and dry it out.  It may be a combination of all the moisture and cold temperatures (we've been down into the mid-20's each night since the rain).

Link to post
Share on other sites

I have the teacups with Santa and the snowmen.   Mine did the same thing last year, then stopped working completely.  Thought at first it may have been the weather.  Tried them again this year before putting them out, but nothing.   I did unzip them to see if something was broke, but everything looked intact.   Figured the motors died.   I posted on here to see if anyone had ideas, but no response.  I have them out with my carnival theme anyway.    People do not know they are supposed to spin.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...