Jump to content

Troubleshooting LEDs


JeffL

Recommended Posts

I have a star that half the string works (second half not fed directly by power).  Depending on which side of the bulb I try the LED keeper on I am able to get all the bulbs to light.  The only thing I know is that it appears the power goes all the way to the end and then back feeds the first half.  Any help troubleshooting would be much appreciated.

StarSmall.jpg

Link to post
Share on other sites
8 hours ago, timpwk said:

Is there a "blob" (resistor, etc.) on the second half?  I wonder if that has gone bad and could be your problem?

agree...if all the bulbs test good, then it is the resistor inside the little blob.  I have cut it out, whittled down the plastic to see what size the resistor is and soldered in a new resistor with success.

Link to post
Share on other sites

Driving me nuts.  I can't get any reading on any of the blobs.  About ready to start hacking it apart. All the LEDs will light but not all from the same direction.  So far it makes no sense to me.

Link to post
Share on other sites
7 hours ago, JeffL said:

All the LEDs will light but not all from the same direction

Are these full wave (non flicker LEDs)?  Is so, that blob has diodes to rectify the power as well.

It is normal that both sides of the LEDs for halfwave LEDs to be built "backwards" as you described.  Where the LEDs are lined up one direction and in the second half they are lined up opposite.  In AC power, it doesn't matter which direction each section is lined up as they only work on half the AC wave cycle anyway.

The only other thing that could be wrong is a broken wire  (where the copper inside is broken but not the insulation), but you should have seen that testing the LEDs though.

There is an article in this magazine covering testing LEDs

http://magazine.planetchristmas.com/Magazine/July2012/index.html#/64/

Link to post
Share on other sites

After many attempts to correct it I added a resistor between the input and output wire of the first LED in the string.  This LED would light from one side but not the other (different from the others)  The only thing I can think of is that there is a resistor in the LED that was toast.  They are sealed so I have no idea.  

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...